WordPress WP Prayer 1.6.1 Cross Site Scripting

2021.06.01
Risk: Low
Local: No
Remote: Yes
CVE: N/A
CWE: CWE-79

# Exploit Title: WordPress Plugin WP Prayer version 1.6.1 - 'prayer_messages' Stored Cross-Site Scripting (XSS) (Authenticated) # Date: 2021-05-31 # Exploit Author: Bastijn Ouwendijk # Vendor Homepage: http://goprayer.com/ # Software Link: https://wordpress.org/plugins/wp-prayer/ # Version: 1.6.1 and earlier # Tested on: Windows 10 # Proof: https://bastijnouwendijk.com/cve-2021-24313/ Steps to exploit this vulnerability: 1. Log into the WordPress website with a user account, can be a user with any role 2. Go to the page where prayer or praise request can be made and fill in the requested information 3. In the 'prayer_messages' field of the prayer request form put the payload: <script>alert("XSS")</script> 4. Submit the form 5. Go to the page where the prayer requests are listed 6. The prayer requests are loaded and an alert is shown with text 'XSS' in the browser


Vote for this issue:
50%
50%


 

Thanks for you vote!


 

Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.


(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2021, cxsecurity.com

 

Back to Top