Podatność CVE-2009-0796


Publikacja: 2009-04-07   Modyfikacja: 2012-02-13

Opis:
Cross-site scripting (XSS) vulnerability in Status.pm in Apache::Status and Apache2::Status in mod_perl1 and mod_perl2 for the Apache HTTP Server, when /perl-status is accessible, allows remote attackers to inject arbitrary web script or HTML via the URI.

Typ:

CWE-79

(Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'))

CVSS2 => (AV:N/AC:H/Au:N/C:N/I:P/A:N)

Ogólna skala CVSS
Znaczenie
Łatwość wykorzystania
2.6/10
2.9/10
4.9/10
Wymagany dostęp
Złożoność ataku
Autoryzacja
Zdalny
Wysoka
Nie wymagana
Wpływ na poufność
Wpływ na integralność
Wpływ na dostępność
Brak
Częściowy
Brak
Affected software
Apache -> Mod perl 

 Referencje:
http://lists.apple.com/archives/security-announce/2010//Nov/msg00000.html
http://sunsolve.sun.com/search/document.do?assetkey=1-77-1021508.1-1
http://sunsolve.sun.com/search/document.do?assetkey=1-77-1021709.1-1
http://support.apple.com/kb/HT4435
http://svn.apache.org/viewvc/perl/modperl/branches/1.x/lib/Apache/Status.pm?r1=177851&r2=761081&pathrev=761081&diff_format=h
http://svn.apache.org/viewvc?view=rev&revision=761081
http://www.gossamer-threads.com/lists/modperl/modperl-cvs/99477#99477
http://www.gossamer-threads.com/lists/modperl/modperl/99475#99475
http://www.mandriva.com/security/advisories?name=MDVSA-2009:091
http://www.securityfocus.com/archive/1/502709/100/0/threaded
http://www.securityfocus.com/bid/34383
http://www.securitytracker.com/id?1021988
http://www.vupen.com/english/advisories/2009/0943
https://bugzilla.redhat.com/show_bug.cgi?id=494402
https://launchpad.net/bugs/cve/2009-0796
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A8488

Copyright 2022, cxsecurity.com

 

Back to Top