Podatność CVE-2010-4707


Publikacja: 2011-01-24   Modyfikacja: 2012-02-13

Opis:
The check_acl function in pam_xauth.c in the pam_xauth module in Linux-PAM (aka pam) 1.1.2 and earlier does not verify that a certain ACL file is a regular file, which might allow local users to cause a denial of service (resource consumption) via a special file.

Typ:

CWE-399

(Resource Management Errors)

CVSS2 => (AV:L/AC:L/Au:N/C:C/I:N/A:N)

Ogólna skala CVSS
Znaczenie
Łatwość wykorzystania
4.9/10
6.9/10
3.9/10
Wymagany dostęp
Złożoność ataku
Autoryzacja
Lokalny
Niska
Nie wymagana
Wpływ na poufność
Wpływ na integralność
Wpływ na dostępność
Pełny
Brak
Brak
Affected software
Linux-pam -> Linux-pam 
Kernel -> Linux-pam 

 Referencje:
http://git.altlinux.org/people/ldv/packages/?p=pam.git;a=commit;h=Linux-PAM-1_1_2-2-gffe7058c70253d574b1963c7c93002bd410fddc9
http://openwall.com/lists/oss-security/2010/10/03/1
http://security.gentoo.org/glsa/glsa-201206-31.xml
http://www.securityfocus.com/bid/46045
https://exchange.xforce.ibmcloud.com/vulnerabilities/65036

Copyright 2022, cxsecurity.com

 

Back to Top