Podatność CVE-2012-3236


Publikacja: 2012-07-12   Modyfikacja: 2012-07-17

Opis:
fits-io.c in GIMP before 2.8.1 allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a malformed XTENSION header of a .fit file, as demonstrated using a long string.

W naszej bazie, znaleźliśmy następujące noty dla tego CVE:
Tytuł
Autor
Data
Low
GIMP 2.8.0 FIT File Format DoS
Joseph Sheridan
29.06.2012

Typ:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:N/A:P)

Ogólna skala CVSS
Znaczenie
Łatwość wykorzystania
4.3/10
2.9/10
8.6/10
Wymagany dostęp
Złożoność ataku
Autoryzacja
Zdalny
Średnia
Nie wymagana
Wpływ na poufność
Wpływ na integralność
Wpływ na dostępność
Brak
Brak
Częściowy
Affected software
GNU -> GIMP 
GIMP -> GIMP 

 Referencje:
http://archives.neohapsis.com/archives/bugtraq/2012-06/0192.html
http://git.gnome.org/browse/gimp/commit/plug-ins/file-fits/fits-io.c?id=ace45631595e8781a1420842582d67160097163c
http://lists.opensuse.org/opensuse-security-announce/2012-09/msg00000.html
http://www.exploit-db.com/exploits/19482
http://www.mandriva.com/security/advisories?name=MDVSA-2013:082
http://www.reactionpenetrationtesting.co.uk/FIT-file-handling-dos.html
http://www.securityfocus.com/bid/54246
http://www.ubuntu.com/usn/USN-1559-1
https://bugzilla.gnome.org/show_bug.cgi?id=676804
https://exchange.xforce.ibmcloud.com/vulnerabilities/76658

Copyright 2022, cxsecurity.com

 

Back to Top