Podatność CVE-2013-0221


Publikacja: 2013-11-23

Opis:
The SUSE coreutils-i18n.patch for GNU coreutils allows context-dependent attackers to cause a denial of service (segmentation fault and crash) via a long string to the sort command, when using the (1) -d or (2) -M switch, which triggers a stack-based buffer overflow in the alloca function.

Typ:

CWE-20

(Improper Input Validation)

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:N/A:P)

Ogólna skala CVSS
Znaczenie
Łatwość wykorzystania
4.3/10
2.9/10
8.6/10
Wymagany dostęp
Złożoność ataku
Autoryzacja
Zdalny
Średnia
Nie wymagana
Wpływ na poufność
Wpływ na integralność
Wpływ na dostępność
Brak
Brak
Częściowy
Affected software
Redhat -> Enterprise linux 
Opensuse -> Opensuse 
Novell -> Opensuse 
GNU -> Coreutils 

 Referencje:
http://rhn.redhat.com/errata/RHSA-2013-1652.html
https://bugzilla.novell.com/show_bug.cgi?id=798538
https://bugzilla.redhat.com/show_bug.cgi?id=903464
https://build.opensuse.org/request/show/149348#diff_headline_coreutils-i18n-patch_diff_action_0_submit_0_19

Copyright 2020, cxsecurity.com

 

Back to Top