Podatność CVE-2016-0363


Publikacja: 2016-06-03

Opis:
The com.ibm.CORBA.iiop.ClientDelegate class in IBM SDK, Java Technology Edition 6 before SR16 FP25 (6.0.16.25), 6 R1 before SR8 FP25 (6.1.8.25), 7 before SR9 FP40 (7.0.9.40), 7 R1 before SR3 FP40 (7.1.3.40), and 8 before SR3 (8.0.3.0) uses the invoke method of the java.lang.reflect.Method class in an AccessController doPrivileged block, which allows remote attackers to call setSecurityManager and bypass a sandbox protection mechanism via vectors related to a Proxy object instance implementing the java.lang.reflect.InvocationHandler interface. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-3009.

Typ:

CWE-20

(Improper Input Validation)

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:P/A:P)

Ogólna skala CVSS
Znaczenie
Łatwość wykorzystania
6.8/10
6.4/10
8.6/10
Wymagany dostęp
Złożoność ataku
Autoryzacja
Zdalny
Średnia
Nie wymagana
Wpływ na poufność
Wpływ na integralność
Wpływ na dostępność
Częściowy
Częściowy
Częściowy
Affected software
Redhat -> Enterprise linux desktop supplementary 
Redhat -> Enterprise linux hpc node supplementary 
Redhat -> Enterprise linux server supplementary 
Redhat -> Enterprise linux server supplementary eus 
Redhat -> Enterprise linux supplementary 
Redhat -> Enterprise linux workstation supplementary 
Novell -> Suse linux enterprise module for legacy software 
Novell -> Suse linux enterprise server 
Novell -> Suse linux enterprise software development kit 
Novell -> Suse manager 
Novell -> Suse manager proxy 
Novell -> Suse openstack cloud 
IBM -> Java sdk 

 Referencje:
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00039.html
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00040.html
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00042.html
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00058.html
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00059.html
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00061.html
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00067.html
http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00002.html
http://rhn.redhat.com/errata/RHSA-2016-0701.html
http://rhn.redhat.com/errata/RHSA-2016-0702.html
http://rhn.redhat.com/errata/RHSA-2016-0708.html
http://rhn.redhat.com/errata/RHSA-2016-0716.html
http://rhn.redhat.com/errata/RHSA-2016-1039.html
http://seclists.org/fulldisclosure/2016/Apr/20
http://seclists.org/fulldisclosure/2016/Apr/3
http://www-01.ibm.com/support/docview.wss?uid=swg1IX90172
http://www-01.ibm.com/support/docview.wss?uid=swg21980826
http://www.security-explorations.com/materials/SE-2012-01-IBM-4.pdf
http://www.securityfocus.com/bid/85895
http://www.securitytracker.com/id/1035953
https://access.redhat.com/errata/RHSA-2016:1430
https://access.redhat.com/errata/RHSA-2017:1216

Copyright 2022, cxsecurity.com

 

Back to Top