Podatność CVE-2016-6639


Publikacja: 2016-09-17   Modyfikacja: 2016-09-18

Opis:
Cloud Foundry PHP Buildpack (aka php-buildpack) before 4.3.18 and PHP Buildpack Cf-release before 242, as used in Pivotal Cloud Foundry (PCF) Elastic Runtime before 1.6.38 and 1.7.x before 1.7.19 and other products, place the .profile file in the htdocs directory, which might allow remote attackers to obtain sensitive information via an HTTP GET request for this file.

Typ:

CWE-254

(Security Features)

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:N/A:N)

Ogólna skala CVSS
Znaczenie
Łatwość wykorzystania
5/10
2.9/10
10/10
Wymagany dostęp
Złożoność ataku
Autoryzacja
Zdalny
Niska
Nie wymagana
Wpływ na poufność
Wpływ na integralność
Wpływ na dostępność
Częściowy
Brak
Brak
Affected software
Pivotal -> Cloud foundry elastic runtime 
Pivotal -> Cloud foundry php buildpack 
Cloud foundry -> Php buildpack 

 Referencje:
https://github.com/cloudfoundry/php-buildpack/commit/e2db3ccd4812e0c0aba20720fc51789d981aba67
https://pivotal.io/security/cve-2016-6639

Copyright 2022, cxsecurity.com

 

Back to Top