Podatność CVE-2017-12185


Publikacja: 2018-01-24

Opis:
xorg-x11-server before 1.19.5 was missing length validation in MIT-SCREEN-SAVER extension allowing malicious X client to cause X server to crash or possibly execute arbitrary code.

Typ:

CWE-20

(Improper Input Validation)

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:P/A:P)

Ogólna skala CVSS
Znaczenie
Łatwość wykorzystania
7.5/10
6.4/10
10/10
Wymagany dostęp
Złożoność ataku
Autoryzacja
Zdalny
Niska
Nie wymagana
Wpływ na poufność
Wpływ na integralność
Wpływ na dostępność
Częściowy
Częściowy
Częściowy
Affected software
X.org -> Xorg-server 
Debian -> Debian linux 

 Referencje:
https://bugzilla.redhat.com/show_bug.cgi?id=1509215
https://cgit.freedesktop.org/xorg/xserver/commit/?id=cad5a1050b7184d828aef9c1dd151c3ab649d37e
https://lists.debian.org/debian-lts-announce/2017/11/msg00032.html
https://www.debian.org/security/2017/dsa-4000

Copyright 2022, cxsecurity.com

 

Back to Top