Podatność CVE-2018-1160


Publikacja: 2018-12-20   Modyfikacja: 2018-12-21

Opis:
Netatalk before 3.1.12 is vulnerable to an out of bounds write in dsi_opensess.c. This is due to lack of bounds checking on attacker controlled data. A remote unauthenticated attacker can leverage this vulnerability to achieve arbitrary code execution.

W naszej bazie, znaleźliśmy następujące noty dla tego CVE:
Tytuł
Autor
Data
Med.
Netatalk Authentication Bypass
Jacob Baines
23.12.2018

Typ:

CWE-787

CVSS2 => (AV:N/AC:L/Au:N/C:C/I:C/A:C)

Ogólna skala CVSS
Znaczenie
Łatwość wykorzystania
10/10
10/10
10/10
Wymagany dostęp
Złożoność ataku
Autoryzacja
Zdalny
Niska
Nie wymagana
Wpływ na poufność
Wpływ na integralność
Wpływ na dostępność
Pełny
Pełny
Pełny
Affected software
Synology -> Skynas 
Synology -> Vs960hd firmware 
Synology -> Diskstation manager 
Synology -> Router manager 
Netatalk project -> Netatalk 
Debian -> Debian linux 

 Referencje:
http://netatalk.sourceforge.net/3.1/ReleaseNotes3.1.12.html
http://packetstormsecurity.com/files/152440/QNAP-Netatalk-Authentication-Bypass.html
http://www.securityfocus.com/bid/106301
https://attachments.samba.org/attachment.cgi?id=14735
https://github.com/tenable/poc/tree/master/netatalk/cve_2018_1160/
https://www.debian.org/security/2018/dsa-4356
https://www.exploit-db.com/exploits/46034/
https://www.exploit-db.com/exploits/46048/
https://www.exploit-db.com/exploits/46675/
https://www.synology.com/security/advisory/Synology_SA_18_62
https://www.tenable.com/security/research/tra-2018-48

Copyright 2022, cxsecurity.com

 

Back to Top