Podatność CVE-2018-20340


Publikacja: 2019-03-21

Opis:
Yubico libu2f-host 1.1.6 contains unchecked buffers in devs.c, which could enable a malicious token to exploit a buffer overflow. An attacker could use this to attempt to execute malicious code using a crafted USB device masquerading as a security token on a computer where the affected library is currently in use. It is not possible to perform this attack with a genuine YubiKey.

Typ:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

CVSS2 => (AV:L/AC:L/Au:N/C:P/I:P/A:P)

Ogólna skala CVSS
Znaczenie
Łatwość wykorzystania
4.6/10
6.4/10
3.9/10
Wymagany dostęp
Złożoność ataku
Autoryzacja
Lokalny
Niska
Nie wymagana
Wpływ na poufność
Wpływ na integralność
Wpływ na dostępność
Częściowy
Częściowy
Częściowy
Affected software
Yubico -> Libu2f-host 
Debian -> Debian linux 

 Referencje:
https://developers.yubico.com/libu2f-host/Release_Notes.html
https://seclists.org/bugtraq/2019/Feb/23
https://www.debian.org/security/2019/dsa-4389
https://www.yubico.com/support/security-advisories/ysa-2019-01/

Copyright 2022, cxsecurity.com

 

Back to Top