Podatność CVE-2019-11036


Publikacja: 2019-05-03

Opis:
When processing certain files, PHP EXIF extension in versions 7.1.x below 7.1.29, 7.2.x below 7.2.18 and 7.3.x below 7.3.5 can be caused to read past allocated buffer in exif_process_IFD_TAG function. This may lead to information disclosure or crash.

Typ:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:N/A:P)

Ogólna skala CVSS
Znaczenie
Łatwość wykorzystania
6.4/10
4.9/10
10/10
Wymagany dostęp
Złożoność ataku
Autoryzacja
Zdalny
Niska
Nie wymagana
Wpływ na poufność
Wpływ na integralność
Wpływ na dostępność
Częściowy
Brak
Częściowy
Affected software
PHP -> PHP 

 Referencje:
http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00010.html
http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00012.html
http://www.securityfocus.com/bid/108177
https://bugs.php.net/bug.php?id=77950
https://lists.debian.org/debian-lts-announce/2019/05/msg00035.html
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/2NFXYNCXZCPYT7ZN4ZLI5EPQQW44FRRO/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/3BY2XUUAN277LS7HKAOGL4DVGAELOJV3/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WN2HLPGEZEF4MFM5YC5FILZB5QEQFP3A/
https://security.netapp.com/advisory/ntap-20190517-0003/
https://usn.ubuntu.com/3566-2/
https://usn.ubuntu.com/4009-1/

Copyright 2020, cxsecurity.com

 

Back to Top