Podatność CVE-2020-10724


Publikacja: 2020-05-19

Opis:
A vulnerability was found in DPDK versions 18.11 and above. The vhost-crypto library code is missing validations for user-supplied values, potentially allowing an information leak through an out-of-bounds memory read.

Typ:

CWE-190

(Integer Overflow or Wraparound)

CVSS2 => (AV:L/AC:L/Au:N/C:P/I:N/A:N)

Ogólna skala CVSS
Znaczenie
Łatwość wykorzystania
2.1/10
2.9/10
3.9/10
Wymagany dostęp
Złożoność ataku
Autoryzacja
Lokalny
Niska
Nie wymagana
Wpływ na poufność
Wpływ na integralność
Wpływ na dostępność
Częściowy
Brak
Brak
Affected software
DPDK -> Data plane development kit 
Canonical -> Ubuntu linux 

 Referencje:
http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00045.html
https://bugs.dpdk.org/show_bug.cgi?id=269
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10724
https://usn.ubuntu.com/4362-1/
https://www.openwall.com/lists/oss-security/2020/05/18/2

Copyright 2020, cxsecurity.com

 

Back to Top