Podatność CVE-2021-45105


Publikacja: 2021-12-18

Opis:
Apache Log4j2 versions 2.0-alpha1 through 2.16.0 (excluding 2.12.3) did not protect from uncontrolled recursion from self-referential lookups. This allows an attacker with control over Thread Context Map data to cause a denial of service when a crafted string is interpreted. This issue was fixed in Log4j 2.17.0 and 2.12.3.

Typ:

CWE-20

(Improper Input Validation)

CVSS2 => (AV:N/AC:L/Au:N/C:N/I:N/A:P)

Ogólna skala CVSS
Znaczenie
Łatwość wykorzystania
5/10
2.9/10
10/10
Wymagany dostęp
Złożoność ataku
Autoryzacja
Zdalny
Niska
Nie wymagana
Wpływ na poufność
Wpływ na integralność
Wpływ na dostępność
Brak
Brak
Częściowy
Affected software
Netapp -> Cloud manager 
Debian -> Debian linux 
Apache -> Log4j 

 Referencje:
https://logging.apache.org/log4j/2.x/security.html
https://security.netapp.com/advisory/ntap-20211218-0001/
http://www.openwall.com/lists/oss-security/2021/12/19/1
https://www.debian.org/security/2021/dsa-5024
https://www.zerodayinitiative.com/advisories/ZDI-21-1541/
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-apache-log4j-qRuKNEbd
https://cert-portal.siemens.com/productcert/pdf/ssa-501673.pdf
https://www.kb.cert.org/vuls/id/930724
https://psirt.global.sonicwall.com/vuln-detail/SNWLID-2021-0032
https://cert-portal.siemens.com/productcert/pdf/ssa-479842.pdf
https://lists.debian.org/debian-lts-announce/2021/12/msg00017.html

Copyright 2022, cxsecurity.com

 

Back to Top