Podatność CVE-2024-23949


Publikacja: 2024-05-28

Opis:
Multiple improper array index validation vulnerabilities exist in the readMSH functionality of libigl v2.5.0. A specially crafted .msh file can lead to an out-of-bounds write. An attacker can provide a malicious file to trigger this vulnerability.This vulnerability concerns the `igl::MshLoader::parse_node_field` function while handling an `ascii`.msh` file.

Typ:

CWE-787

 Referencje:
https://talosintelligence.com/vulnerability_reports/TALOS-2024-1926

Copyright 2024, cxsecurity.com

 

Back to Top