RSS   Vulnerabilities for 'Aria2'   RSS

2010-05-17
 
CVE-2010-1512

CWE-22
 

 
Directory traversal vulnerability in aria2 before 1.9.3 allows remote attackers to create arbitrary files via directory traversal sequences in the name attribute of a file element in a metalink file.

 
2009-10-20
 
CVE-2009-3617

CWE-134
 

 
Format string vulnerability in the AbstractCommand::onAbort function in src/AbstractCommand.cc in aria2 before 1.6.2, when logging is enabled, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via format string specifiers in a download URI. NOTE: some of these details are obtained from third party information.

 
2009-10-07
 
CVE-2009-3575

CWE-noinfo
 

 
Buffer overflow in DHTRoutingTableDeserializer.cc in aria2 0.15.3, 1.2.0, and other versions allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors.

 


Copyright 2017, cxsecurity.com

 

Back to Top