RSS   Vulnerabilities for 'Ncompress'   RSS

2006-08-14
 
CVE-2006-1168

 

 
The decompress function in compress42.c in (1) ncompress 4.2.4 and (2) liblzw allows remote attackers to cause a denial of service (crash), and possibly execute arbitrary code, via crafted data that leads to a buffer underflow.

 
2005-09-20
 
CVE-2005-2991

 

 
ncompress 4.2.4 and earlier allows local users to overwrite arbitrary files via a symlink attack on temporary files using (1) zdiff or (2) zcmp, a different vulnerability than CVE-2004-0970.

 
2004-12-23
 
CVE-2001-1413

 

 
Stack-based buffer overflow in the comprexx function for ncompress 4.2.4 and earlier, when used in situations that cross security boundaries (such as FTP server), may allow remote attackers to execute arbitrary code via a long filename argument.

 


Copyright 2019, cxsecurity.com

 

Back to Top