RSS   Vulnerabilities for 'Tikiwiki cms/groupware'   RSS

2019-08-22
 
CVE-2019-15314

CWE-79
 

 
tiki/tiki-upload_file.php in Tiki 18.4 allows remote attackers to upload JavaScript code that is executed upon visiting a tiki/tiki-download_file.php?display&fileId= URI.

 
2019-01-15
 
CVE-2018-20719

CWE-89
 

 
In Tiki before 17.2, the user task component is vulnerable to a SQL Injection via the tiki-user_tasks.php show_history parameter.

 
2018-08-13
 
CVE-2018-14850

CWE-79
 

 
Stored XSS vulnerabilities in Tiki before 18.2, 15.7 and 12.14 allow an authenticated user injecting JavaScript to gain administrator privileges if an administrator opens a wiki page and moves the mouse pointer over a modified link or thumb image.

 
 
CVE-2018-14849

CWE-79
 

 
Tiki before 18.2, 15.7 and 12.14 has XSS via link attributes, related to lib/core/WikiParser/OutputLink.php and lib/parser/parserlib.php.

 
2018-03-09
 
CVE-2018-7290

CWE-79
 

 
Cross Site Scripting (XSS) exists in Tiki before 12.13, 15.6, 17.2, and 18.1.

 
2018-02-21
 
CVE-2018-7303

CWE-79
 

 
The Calendar component in Tiki 17.1 allows HTML injection.

 
2018-02-16
 
CVE-2018-7188

CWE-79
 

 
An XSS vulnerability (via an SVG image) in Tiki before 18 allows an authenticated user to gain administrator privileges if an administrator opens a wiki page with a malicious SVG image, related to lib/filegals/filegallib.php.

 
2018-02-06
 
CVE-2016-7394

CWE-79
 

 
tiki wiki cms groupware <=15.2 has a xss vulnerability, allow attackers steal user's cookie.

 
2017-09-29
 
CVE-2017-14925

 

 
Cross-Site Request Forgery (CSRF) vulnerability via IMG element in Tiki before 16.3, 17.x before 17.1, 12 LTS before 12.12 LTS, and 15 LTS before 15.5 LTS allows an authenticated user to edit global permissions if an administrator opens a wiki page with an IMG element, related to tiki-objectpermissions.php. For example, an attacker could assign administrator privileges to every unauthenticated user of the site.

 
 
CVE-2017-14924

 

 
Cross-Site Request Forgery (CSRF) vulnerability via IMG element in Tiki before 16.3, 17.x before 17.1, 12 LTS before 12.12 LTS, and 15 LTS before 15.5 LTS allows an authenticated user to gain administrator privileges if an administrator opens a wiki page with an IMG element, related to tiki-assignuser.php.

 


Copyright 2022, cxsecurity.com

 

Back to Top