RSS   Vulnerabilities for 'Gitlist'   RSS

2018-06-26
 
CVE-2018-1000533

CWE-20
 

 
klaussilveira GitList version <= 0.6 contains a Passing incorrectly sanitized input to system function vulnerability in `searchTree` function that can result in Execute any code as PHP user. This attack appear to be exploitable via Send POST request using search form. This vulnerability appears to have been fixed in 0.7 after commit 87b8c26b023c3fc37f0796b14bb13710f397b322.

 
2014-07-22
 
CVE-2014-5023

CWE-Other
 

 
Repository.php in Gitter, as used in Gitlist, allows remote attackers with commit privileges to execute arbitrary commands via shell metacharacters in a branch name, as demonstrated by a "git checkout -b" command.

 
 
CVE-2014-4511

CWE-Other
 

 
Gitlist before 0.5.0 allows remote attackers to execute arbitrary commands via shell metacharacters in the file name in the URI of a request for a (1) blame, (2) file, or (3) stats page, as demonstrated by requests to blame/master/, master/, and stats/master/.

 
 
CVE-2013-7392

CWE-Other
 

 
Gitlist allows remote attackers to execute arbitrary commands via shell metacharacters in a file name to Source/.

 


Copyright 2022, cxsecurity.com

 

Back to Top