RSS   Vulnerabilities for 'Spring boot'   RSS

2018-03-19
 
CVE-2018-1196

CWE-59
 

 
Spring Boot supports an embedded launch script that can be used to easily run the application as a systemd or init.d linux service. The script included with Spring Boot 1.5.9 and earlier and 2.0.0.M1 through 2.0.0.M7 is susceptible to a symlink attack which allows the "run_user" to overwrite and take ownership of any file on the same system. In order to instigate the attack, the application must be installed as a service and the "run_user" requires shell access to the server. Spring Boot application that are not installed as a service, or are not using the embedded launch script are not susceptible.

 
2018-01-04
 
CVE-2017-8046

CWE-20
 

 
Malicious PATCH requests submitted to servers using Spring Data REST versions prior to 2.6.9 (Ingalls SR9), versions prior to 3.0.1 (Kay SR1) and Spring Boot versions prior to 1.5.9, 2.0 M6 can use specially crafted JSON data to run arbitrary Java code.

 

 >>> Vendor: Pivotal software 48 Products
Rabbitmq management
Rabbitmq
Spring framework
Redis
Cloud foundry
Cloud foundry elastic runtime
Cloud foundry ops manager
Cloud foundry uaa
Cloud foundry uaa bosh
Operations manager
Spring data jpa
Cloud foundry cf mysql
Greenplum
Gemfire for pivotal cloud foundry
Spring security
Cloud foundry elastic runtime cf release
Cloud foundry uaa release
Login-server
Cloud foundry cf release
Cloud foundry garden linux
Cloud foundry cf
Spring social
Single sign-on for pivotal cloud foundry
Grootfs
Spring advanced message queuing protocol
Cf-deployment
Spring-ldap
Cf-release
Uaa-release
Credhub-release
Spring data rest
Cloud foundry uaa-release
Spring boot
Spring batch admin
Mysql
Spring data commons
Spring cloud sso connector
Spring security oauth
Windows stemcells
Spring integration zip
Pivotal application service
Cloud foundry cf-deployment
Cloudfoundry uaa release
Cloudfoundry uaa
Spring batch
Spring integration
Spring web services
Concourse


Copyright 2019, cxsecurity.com

 

Back to Top