RSS   Vulnerabilities for 'Confire'   RSS

2017-11-10
 
CVE-2017-16763

CWE-77
 

 
An exploitable vulnerability exists in the YAML parsing functionality in config.py in Confire 0.2.0. Due to the user-specific configuration being loaded from "~/.confire.yaml" using the yaml.load function, a YAML parser can execute arbitrary Python commands resulting in command execution. An attacker can insert Python into loaded YAML to trigger this vulnerability.

 


Copyright 2019, cxsecurity.com

 

Back to Top