RSS   Vulnerabilities for 'Ethereum virtual machine'   RSS

2018-01-19
 
CVE-2017-14457

CWE-125
 

 
An exploitable information leak/denial of service vulnerability exists in the libevm (Ethereum Virtual Machine) `create2` opcode handler of CPP-Ethereum. A specially crafted smart contract code can cause an out-of-bounds read leading to memory disclosure or denial of service. An attacker can create/send malicious a smart contract to trigger this vulnerability.

 

 >>> Vendor: Ethereum 4 Products
Cpp-ethereum
Ethereum virtual machine
Go ethereum
Py-evm


Copyright 2019, cxsecurity.com

 

Back to Top