RSS   Vulnerabilities for 'Intouch edge hmi'   RSS

2018-11-02
 
CVE-2018-17916

CWE-119
 

 
InduSoft Web Studio versions prior to 8.1 SP2, and InTouch Edge HMI (formerly InTouch Machine Edition) versions prior to 2017 SP2. A remote attacker could send a carefully crafted packet to exploit a stack-based buffer overflow vulnerability during tag, alarm, or event related actions such as read and write, with potential for code to be executed. If InduSoft Web Studio remote communication security was not enabled, or a password was left blank, a remote user could send a carefully crafted packet to invoke an arbitrary process, with potential for code to be executed. The code would be executed under the privileges of the InduSoft Web Studio or InTouch Edge HMI runtime and could lead to a compromise of the InduSoft Web Studio or InTouch Edge HMI server machine.

 
 
CVE-2018-17914

CWE-noinfo
 

 
InduSoft Web Studio versions prior to 8.1 SP2, and InTouch Edge HMI (formerly InTouch Machine Edition) versions prior to 2017 SP2. This vulnerability could allow an unauthenticated user to remotely execute code with the same privileges as that of the InduSoft Web Studio or InTouch Edge HMI (formerly InTouch Machine Edition) runtime.

 

 >>> Vendor: Aveva 11 Products
Indusoft web studio
Intouch machine 2017
Intouch 2014
Intouch 2017
Intouch edge hmi
Intouch machine edition 2014
Clearscada
Wonderware system platform
Edna enterprise data historian
Suitelink
System platform


Copyright 2023, cxsecurity.com

 

Back to Top