RSS   Vulnerabilities for 'Aioxmpp'   RSS

2019-02-04
 
CVE-2019-1000007

CWE-19
 

 
aioxmpp version 0.10.2 and earlier contains a Improper Handling of Structural Elements vulnerability in Stanza Parser, rollback during error processing, aioxmpp.xso.model.guard function that can result in Denial of Service, Other. This attack appears to be exploitable via Remote. A crafted stanza can be sent to an application which uses the vulnerable components to either inject data in a different context or cause the application to reconnect (potentially losing data). This vulnerability appears to have been fixed in 0.10.3.

 


Copyright 2019, cxsecurity.com

 

Back to Top