RSS   Vulnerabilities for 'Flexair'   RSS

2019-07-01
 
CVE-2019-7670

CWE-77
 

 
Prima Systems FlexAir, Versions 2.3.38 and prior. The application incorrectly neutralizes special elements that could modify the intended OS command when it is sent to a downstream component, which could allow attackers to execute commands directly on the operating system.

 
 
CVE-2019-7669

CWE-77
 

 
Prima Systems FlexAir, Versions 2.3.38 and prior. Improper validation of file extensions when uploading files could allow a remote authenticated attacker to upload and execute malicious applications within the application?s web root with root privileges.

 
 
CVE-2019-7668

CWE-255
 

 
Prima Systems FlexAir devices have Default Credentials.

 
 
CVE-2019-7667

CWE-287
 

 
Prima Systems FlexAir, Versions 2.3.38 and prior. The application generates database backup files with a predictable name, and an attacker can use brute force to identify the database backup file name. A malicious actor can exploit this issue to download the database file and disclose login information, which can allow the attacker to bypass authentication and have full access to the system.

 
 
CVE-2019-7666

CWE-287
 

 
Prima Systems FlexAir, Versions 2.3.38 and prior. The application allows improper authentication using the MD5 hash value of the password, which may allow an attacker with access to the database to login as admin without decrypting the password.

 
 
CVE-2019-7281

CWE-352
 

 
Prima Systems FlexAir, Versions 2.3.38 and prior. An unauthenticated user can send unverified HTTP requests, which may allow the attacker to perform certain actions with administrative privileges if a logged-in user visits a malicious website.

 
 
CVE-2019-7280

CWE-613
 

 
Prima Systems FlexAir, Versions 2.3.38 and prior. The session-ID is of an insufficient length and can be exploited by brute force, which may allow a remote attacker to obtain a valid session and bypass authentication.

 
2019-06-05
 
CVE-2019-9189

CWE-434
 

 
Prima Systems FlexAir, Versions 2.4.9api3 and prior. The application allows the upload of arbitrary Python scripts when configuring the main central controller. These scripts can be immediately executed because of root code execution, not as a web server user, allowing an authenticated attacker to gain full system access.

 
 
CVE-2019-7672

CWE-798
 

 
Prima Systems FlexAir, Versions 2.3.38 and prior. The flash version of the web interface contains a hard-coded username and password, which may allow an authenticated attacker to escalate privileges.

 
 
CVE-2019-7671

CWE-79
 

 
Prima Systems FlexAir, Versions 2.3.38 and prior. Parameters sent to scripts are not properly sanitized before being returned to the user, which may allow an attacker to execute arbitrary code in a user?s browser session in context of an affected site.

 


Copyright 2019, cxsecurity.com

 

Back to Top