RSS   Vulnerabilities for 'Simple 301 redirects'   RSS

2021-06-14
 
CVE-2021-24352

CWE-284
 

 
The export_data function of the Simple 301 Redirects by BetterLinks WordPress plugin before 2.0.4 had no capability or nonce checks making it possible for unauthenticated users to export a site's redirects.

 
 
CVE-2021-24353

CWE-284
 

 
The import_data function of the Simple 301 Redirects by BetterLinks WordPress plugin before 2.0.4 had no capability or nonce checks making it possible for unauthenticated users to import a set of site redirects.

 
 
CVE-2021-24354

CWE-269
 

 
A lack of capability checks and insufficient nonce check on the AJAX action in the Simple 301 Redirects by BetterLinks WordPress plugin before 2.0.4, made it possible for authenticated users to install arbitrary plugins on vulnerable sites.

 
 
CVE-2021-24355

CWE-284
 

 
In the Simple 301 Redirects by BetterLinks WordPress plugin before 2.0.4, the lack of capability checks and insufficient nonce check on the AJAX actions, simple301redirects/admin/get_wildcard and simple301redirects/admin/wildcard, made it possible for authenticated users to retrieve and update the wildcard value for redirects.

 
 
CVE-2021-24356

CWE-284
 

 
In the Simple 301 Redirects by BetterLinks WordPress plugin before 2.0.4, a lack of capability checks and insufficient nonce check on the AJAX action, simple301redirects/admin/activate_plugin, made it possible for authenticated users to activate arbitrary plugins installed on vulnerable sites.

 

 >>> Vendor: Wpdeveloper 5 Products
Twitter cards meta
Essential addons for elementor
Simple 301 redirects
Countdown block
Betterlinks


Copyright 2022, cxsecurity.com

 

Back to Top