RSS   Vulnerabilities for 'Aegir'   RSS

2020-05-27
 
CVE-2020-11059

CWE-200
 

 
In AEgir greater than or equal to 21.7.0 and less than 21.10.1, aegir publish and aegir build may leak secrets from environment variables in the browser bundle published to npm. This has been fixed in 21.10.1.

 
2018-06-06
 
CVE-2017-16225

CWE-200
 

 
aegir is a module to help automate JavaScript project management. Version 12.0.0 through and including 12.0.7 bundled and published to npm the user (that performed a aegir-release) GitHub token.

 


Copyright 2020, cxsecurity.com

 

Back to Top