RSS   Vulnerabilities for 'Racoon'   RSS

2005-03-14
 
CVE-2005-0398

 

 
The KAME racoon daemon in ipsec-tools before 0.5 allows remote attackers to cause a denial of service (crash) via malformed ISAKMP packets.

 
2004-12-06
 
CVE-2004-0607

 

 
The eay_check_x509cert function in KAME Racoon successfully verifies certificates even when OpenSSL validation fails, which could allow remote attackers to bypass authentication.

 
2004-06-01
 
CVE-2004-0403

 

 
Racoon before 20040408a allows remote attackers to cause a denial of service (memory consumption) via an ISAKMP packet with a large length field.

 
2004-06-14
 
CVE-2004-0392

 

 
racoon before 20040407b allows remote attackers to cause a denial of service (infinite loop and dropped connections) via an IKE message with a malformed Generic Payload Header containing invalid (1) "Security Association Next Payload" and (2) "RESERVED" fields.

 
2004-03-03
 
CVE-2004-0164

 

 
KAME IKE daemon (racoon) does not properly handle hash values, which allows remote attackers to delete certificates via (1) a certain delete message that is not properly handled in isakmp.c or isakmp_inf.c, or (2) a certain INITIAL-CONTACT message that is not properly handled in isakmp_inf.c.

 
2004-06-01
 
CVE-2004-0155

 

 
The KAME IKE Daemon Racoon, when authenticating a peer during Phase 1, validates the X.509 certificate but does not verify the RSA signature authentication, which allows remote attackers to establish unauthorized IP connections or conduct man-in-the-middle attacks using a valid, trusted X.509 certificate.

 

 >>> Vendor: KAME 3 Products
Racoon
Ipcomp
KAME


Copyright 2022, cxsecurity.com

 

Back to Top