RSS   Vulnerabilities for 'Js-libp2p-noise'   RSS

2022-03-17
 
CVE-2022-24759

CWE-347
 

 
`@chainsafe/libp2p-noise` contains TypeScript implementation of noise protocol, an encryption protocol used in libp2p. `@chainsafe/libp2p-noise` before 4.1.2 and 5.0.3 does not correctly validate signatures during the handshake process. This may allow a man-in-the-middle to pose as other peers and get those peers banned. Users should upgrade to version 4.1.2 or 5.0.3 to receive a patch. There are currently no known workarounds.

 

 >>> Vendor: Chainsafe 2 Products
Ethermint
Js-libp2p-noise


Copyright 2022, cxsecurity.com

 

Back to Top