RSS   Vulnerabilities for 'Accesslog'   RSS

2022-03-17
 
CVE-2022-25760

CWE-94
 

 
All versions of package accesslog are vulnerable to Arbitrary Code Injection due to the usage of the Function constructor without input sanitization. If (attacker-controlled) user input is given to the format option of the package's exported constructor function, it is possible for an attacker to execute arbitrary JavaScript code on the host that this package is being run on.

 


Copyright 2023, cxsecurity.com

 

Back to Top