RSS   Vulnerabilities for 'KPPP'   RSS

2005-05-02
 
CVE-2005-0205

 

 
KPPP 2.1.2 in KDE 3.1.5 and earlier, when setuid root without certain wrappers, does not properly close a privileged file descriptor for a domain socket, which allows local users to read and write to /etc/hosts and /etc/resolv.conf and gain control over DNS name resolution by opening a number of file descriptors before executing kppp.

 


Copyright 2019, cxsecurity.com

 

Back to Top