RSS   Vulnerabilities for 'Yassl'   RSS

2008-01-10
 
CVE-2008-0227

CWE-119
 

 
yaSSL 1.7.5 and earlier, as used in MySQL and possibly other products, allows remote attackers to cause a denial of service (crash) via a Hello packet containing a large size value, which triggers a buffer over-read in the HASHwithTransform::Update function in hash.cpp.

 
 
CVE-2008-0226

CWE-119
 

 
Multiple buffer overflows in yaSSL 1.7.5 and earlier, as used in MySQL and possibly other products, allow remote attackers to execute arbitrary code via (1) the ProcessOldClientHello function in handshake.cpp or (2) "input_buffer& operator>>" in yassl_imp.cpp.

 
2005-11-21
 
CVE-2005-3731

 

 
Unspecified vulnerability in yaSSL before 1.0.6 has unknown impact and attack vectors, related to "certificate chain processing."

 

 >>> Vendor: Yassl 3 Products
Yassl
Yasslews
Cyassl


Copyright 2019, cxsecurity.com

 

Back to Top