RSS   Vulnerabilities for 'Viart shop'   RSS

2009-04-28
 
CVE-2008-6766

CWE-noinfo
 

 
cart_save.php in ViArt Shop (aka Shopping Cart) 3.5 allows remote attackers to cause a denial of service (excessive shopping carts) via a flood of requests.

 
 
CVE-2008-6765

CWE-noinfo
 

 
ViArt Shop (aka Shopping Cart) 3.5 allows remote attackers to access the contents of an arbitrary shopping cart via a modified cart_name parameter.

 
 
CVE-2008-6760

CWE-59
 

 
ViArt Shop (aka Shopping Cart) 3.5 allows remote attackers to obtain sensitive information via an unauthenticated add and save action for a shopping cart in cart_save.php, which reveals the SQL table names in an error message, related to code that mishandles the lack of a user_id parameter.

 
 
CVE-2008-6759

CWE-59
 

 
ViArt Shop (aka Shopping Cart) 3.5 allows remote attackers to obtain sensitive information via a URL in the POST_DATA parameter to manuals_search.php, which reveals the installation path in an error message.

 
 
CVE-2008-6758

CWE-352
 

 
Cross-site request forgery (CSRF) vulnerability in cart_save.php in ViArt Shop (aka Shopping Cart) 3.5 allows remote attackers to hijack the authentication of arbitrary users for requests that conduct persistent cross-site scripting (XSS) attacks via the cart_name parameter in a save action.

 
 
CVE-2008-6757

CWE-79
 

 
Cross-site scripting (XSS) vulnerability in manuals_search.php in ViArt Shop (aka Shopping Cart) 3.5 allows remote attackers to inject arbitrary web script or HTML via the manuals_search parameter.

 
2008-07-30
 
CVE-2008-3369

CWE-89
 

 
SQL injection vulnerability in products_rss.php in ViArt Shop 3.5 and earlier allows remote attackers to execute arbitrary SQL commands via the category_id parameter.

 

 >>> Vendor: Viart 9 Products
SHOP
Shopping cart
CMS
Helpdesk
Shop evaluation
Shop free
Viart shop
Viart cms
Viart helpdesk


Copyright 2019, cxsecurity.com

 

Back to Top