RSS   Vulnerabilities for 'Engine'   RSS

2007-03-06
 
CVE-2007-1285

CWE-119
 

 
The Zend Engine in PHP 4.x before 4.4.7, and 5.x before 5.2.2, allows remote attackers to cause a denial of service (stack exhaustion and PHP crash) via deeply nested arrays, which trigger deep recursion in the variable destruction routines.

 
2007-02-20
 
CVE-2007-0988

CWE-119
 

 
The zend_hash_init function in PHP 5 before 5.2.1 and PHP 4 before 4.4.5, when running on a 64-bit platform, allows context-dependent attackers to cause a denial of service (infinite loop) by unserializing certain integer expressions, which only cause 32-bit arguments to be used after the check for a negative value, as demonstrated by an "a:2147483649:{" argument.

 
2007-02-13
 
CVE-2007-0908

CWE-20
 

 
The WDDX deserializer in the wddx extension in PHP 5 before 5.2.1 and PHP 4 before 4.4.5 does not properly initialize the key_length variable for a numerical key, which allows context-dependent attackers to read stack memory via a wddxPacket element that contains a variable with a string name before a numerical variable.

 

 >>> Vendor: ZEND 23 Products
Zend platform
Zend google data client library preview
Zend framework preview
Engine
Framework
Server
Zend server
Zend framework
Zendto
Zend openid
Zendopenid
Zendrest
Zendservice amazon
Zendservice api
Zendservice audioscrobbler
Zendservice nirvanix
Zendservice slideshare
Zendservice technorati
Zendservice windowsazure
Zend-cache
Zf-apigility-doctrine
Zend-mail
Diactoros


Copyright 2021, cxsecurity.com

 

Back to Top