RSS   Vulnerabilities for 'Live555 media server'   RSS

2019-01-14
 
CVE-2019-6256

CWE-20
 

 
A Denial of Service issue was discovered in the LIVE555 Streaming Media libraries as used in Live555 Media Server 0.93. It can cause an RTSPServer crash in handleHTTPCmd_TunnelingPOST, when RTSP-over-HTTP tunneling is supported, via x-sessioncookie HTTP headers in a GET request and a POST request within the same TCP session. This occurs because of a call to an incorrect virtual function pointer in the readSocket function in GroupsockHelper.cpp.

 
2018-10-19
 
CVE-2018-4013

CWE-119
 

 
An exploitable code execution vulnerability exists in the HTTP packet-parsing functionality of the LIVE555 RTSP server library version 0.92. A specially crafted packet can cause a stack-based buffer overflow, resulting in code execution. An attacker can send a packet to trigger this vulnerability.

 

 >>> Vendor: Live555 3 Products
Media server
Streaming media
Live555 media server


Copyright 2019, cxsecurity.com

 

Back to Top