RSS   Vulnerabilities for 'Libzypp'   RSS

2018-08-31
 
CVE-2018-7685

CWE-347
 

 
The decoupled download and installation steps in libzypp before 17.5.0 could lead to a corrupted RPM being left in the cache, where a later call would not display the corrupted RPM warning and allow installation, a problem caused by malicious warnings only displayed during download.

 
2018-03-01
 
CVE-2017-9269

CWE-20
 

 
In libzypp before August 2018 GPG keys attached to YUM repositories were not correctly pinned, allowing malicious repository mirrors to silently downgrade to unsigned repositories with potential malicious content.

 
 
CVE-2017-7436

CWE-20
 

 
In libzypp before 20170803 it was possible to retrieve unsigned packages without a warning to the user which could lead to man in the middle or malicious servers to inject malicious RPM packages into a users system.

 
 
CVE-2017-7435

CWE-20
 

 
In libzypp before 20170803 it was possible to add unsigned YUM repositories without warning to the user that could lead to man in the middle or malicious servers to inject malicious RPM packages into a users system.

 

 >>> Vendor: Opensuse 29 Products
Opensuse
Zypper
Libxcrypt
OSC
SRVX
Evergreen
Libstorage
Libstorage-ng
Suse linux enterprise desktop
Suse linux enterprise server
Suse linux enterprise software development kit
Linux enterprise desktop
Linux enterprise workstation extension
Nonfree
LEAP
Libzypp
Cryptctl
Open build service
Sysconfig
Libsolv
Opensuse leap
Yast2-samba-provision
Yast2-printer
Backports
Backports sle
Wicked
Tumbleweed
Cyrus-sasl
Factory


Copyright 2022, cxsecurity.com

 

Back to Top