RSS   Vulnerabilities for 'Amaya'   RSS

2009-04-01
 
CVE-2009-1209

CWE-119
 

 
Stack-based buffer overflow in W3C Amaya Web Browser 11.1 allows remote attackers to execute arbitrary code via a script tag with a long defer attribute.

 
2009-01-28
 
CVE-2009-0323

CWE-119
 

 
Multiple stack-based buffer overflows in W3C Amaya Web Browser 10.0 and 11.0 allow remote attackers to execute arbitrary code via (1) a long type parameter in an input tag, which is not properly handled by the EndOfXmlAttributeValue function; (2) an "HTML GI" in a start tag, which is not properly handled by the ProcessStartGI function; and unspecified vectors in (3) html2thot.c and (4) xml2thot.c, related to the msgBuffer variable. NOTE: these are different vectors than CVE-2008-6005.

 

 >>> Vendor: W3 2 Products
Amaya
Epubcheck


Copyright 2022, cxsecurity.com

 

Back to Top