RSS   Vulnerabilities for 'Answer and question script'   RSS

2009-05-18
 
CVE-2009-1665

CWE-264
 

 
myaccount.php in Easy Scripts Answer and Question Script allows remote attackers to remove arbitrary user accounts via a modified userid parameter without specifying any additional fields.

 
 
CVE-2009-1664

CWE-287
 

 
myaccount.php in Easy Scripts Answer and Question Script does not verify the original password before changing passwords, which allows remote attackers to change the password of other users and gain privileges via modified userid, txtpassword, and txtRpassword parameters.

 
 
CVE-2009-1663

CWE-Other
 

 
Unrestricted file upload vulnerability in myaccount.php in Easy Scripts Answer and Question Script allows remote attackers to execute arbitrary code by uploading a file with an executable extension, then accessing it via a direct request to the file in the uploads/[username] directory.

 
2009-05-16
 
CVE-2009-1655

CWE-89
 

 
Multiple SQL injection vulnerabilities in myaccount.php in Easy Scripts Answer and Question Script allow remote authenticated users to execute arbitrary SQL commands via the (1) user name (userid parameter) and (2) password.

 
 
CVE-2009-1654

CWE-79
 

 
Cross-site scripting (XSS) vulnerability in questiondetail.php in Easy Scripts Answer and Question Script allows remote attackers to inject arbitrary web script or HTML via the questionid parameter.

 


Copyright 2017, cxsecurity.com

 

Back to Top