RSS   Podatności dla 'U.motion builder'   RSS

2019-05-22
 
CVE-2018-7841

CWE-89
 

 
A SQL Injection (CWE-89) vulnerability exists in U.motion Builder software version 1.3.4 which could cause unwanted code execution when an improper set of characters is entered.

 
2018-07-03
 
CVE-2018-7787

CWE-20
 

 
In Schneider Electric U.motion Builder software versions prior to v1.3.4, this vulnerability is due to improper validation of input of context parameter in HTTP GET request.

 
 
CVE-2018-7786

CWE-79
 

 
In Schneider Electric U.motion Builder software versions prior to v1.3.4, a cross site scripting (XSS) vulnerability exists which could allow injection of malicious scripts.

 
 
CVE-2018-7785

CWE-77
 

 
In Schneider Electric U.motion Builder software versions prior to v1.3.4, a remote command injection allows authentication bypass.

 
 
CVE-2018-7777

CWE-20
 

 
The vulnerability is due to insufficient handling of update_file request parameter on update_module.php in Schneider Electric U.motion Builder software versions prior to v1.3.4. A remote, authenticated attacker can exploit this vulnerability by sending a crafted request to the target server.

 
 
CVE-2018-7776

CWE-200
 

 
The vulnerability exists within error.php in Schneider Electric U.motion Builder software versions prior to v1.3.4. System information is returned to the attacker that contains sensitive data.

 
 
CVE-2018-7774

CWE-89
 

 
The vulnerability exists within processing of localize.php in Schneider Electric U.motion Builder software versions prior to v1.3.4. The underlying SQLite database query is subject to SQL injection on the username input parameter.

 
 
CVE-2018-7773

CWE-89
 

 
The vulnerability exists within processing of nfcserver.php in Schneider Electric U.motion Builder software versions prior to v1.3.4. The underlying SQLite database query is subject to SQL injection on the sessionid input parameter.

 
 
CVE-2018-7772

CWE-89
 

 
The vulnerability exists within processing of applets which are exposed on the web service in Schneider Electric U.motion Builder software versions prior to v1.3.4. The underlying SQLite database query to determine whether a user is logged in is subject to SQL injection on the loginSeed parameter, which can be embedded in the HTTP cookie of the request.

 
 
CVE-2018-7771

CWE-22
 

 
The vulnerability exists within processing of editscript.php in Schneider Electric U.motion Builder software versions prior to v1.3.4. A directory traversal vulnerability allows a caller with standard user privileges to write arbitrary php files anywhere in the web service directory tree.

 


Copyright 2020, cxsecurity.com

 

Back to Top