RSS   Podatności dla
'Pacemaker command line interface'
   RSS

2018-04-12
 
CVE-2018-1086

CWE-200
 

 
pcs before versions 0.9.164 and 0.10 is vulnerable to a debug parameter removal bypass. REST interface of the pcsd service did not properly remove the pcs debug argument from the /run_pcs query, possibly disclosing sensitive information. A remote attacker with a valid token could use this flaw to elevate their privilege.

 
 
CVE-2018-1079

CWE-22
 

 
pcs before version 0.9.164 and 0.10 is vulnerable to a privilege escalation via authorized user malicious REST call. The REST interface of the pcsd service did not properly sanitize the file name from the /remote/put_file query. If the /etc/booth directory exists, an authenticated attacker with write permissions could create or overwrite arbitrary files with arbitrary data outside of the /etc/booth directory, in the context of the pcsd process.

 

 >>> Vendor: Clusterlabs 7 Produkty
Pacemaker
PCS
Pacemaker command line interface
Libqb
Fence-agents
Crmsh
Cluster glue


Copyright 2022, cxsecurity.com

 

Back to Top