RSS   Podatności dla 'Plc editor'   RSS

2021-11-22
 
CVE-2021-42705

CWE-121
 

 
PLC Editor Versions 1.3.8 and prior is vulnerable to a stack-based buffer overflow while processing project files, which may allow an attacker to execute arbitrary code.

 
 
CVE-2021-42707

CWE-787
 

 
PLC Editor Versions 1.3.8 and prior is vulnerable to an out-of-bounds write while processing project files, which may allow an attacker to execute arbitrary code.

 
2020-12-01
 
CVE-2020-25181

CWE-125
 

 
WECON PLC Editor Versions 1.3.8 and prior has a heap-based buffer overflow vulnerabilities have been identified that may allow arbitrary code execution.

 
 
CVE-2020-25177

CWE-787
 

 
WECON PLC Editor Versions 1.3.8 and prior has a stack-based buffer overflow vulnerability has been identified that may allow arbitrary code execution.

 
2019-12-23
 
CVE-2019-18236

CWE-119
 

 
Multiple buffer overflow vulnerabilities exist when the PLC Editor Version 1.3.5_20190129 processes project files. An attacker could use a specially crafted project file to exploit and execute code under the privileges of the application.

 
2018-09-19
 
CVE-2018-14792

CWE-119
 

 
WECON PLC Editor version 1.3.3U may allow an attacker to execute code under the current process when processing project files.

 

 >>> Vendor: We-con 9 Produkty
Levi studio hmi editor
Levi studio hmi
Levistudio hmi editor firmware
Levistudio hmi editor
Levistudiou
Pi studio hmi project programmer
Plc editor
Pi studio
Pi studio hmi


Copyright 2022, cxsecurity.com

 

Back to Top