RSS   Podatności dla 'Slocate'   RSS

2007-01-12
 
CVE-2007-0227

CWE-Other
 

 
slocate 3.1 does not properly manage database entries that specify names of files in protected directories, which allows local users to obtain the names of private files. NOTE: another researcher reports that the issue is not present in slocate 2.7.

 
2005-08-23
 
CVE-2005-2499

 

 
slocate before 2.7 does not properly process very long paths, which allows local users to cause a denial of service (updatedb exit and incomplete slocate database) via a certain crafted directory structure.

 
2003-11-17
 
CVE-2003-0848

 

 
Heap-based buffer overflow in main.c of slocate 2.6, and possibly other versions, may allow local users to gain privileges via a modified slocate database that causes a negative "pathlen" value to be used.

 
2003-06-09
 
CVE-2003-0326

 

 
Integer overflow in parse_decode_path() of slocate may allow attackers to execute arbitrary code via a LOCATE_PATH with a large number of ":" (colon) characters, whose count is used in a call to malloc.

 
2003-02-19
 
CVE-2003-0056

 

 
Buffer overflow in secure locate (slocate) before 2.7 allows local users to execute arbitrary code via a long (1) -c or (2) -r command line argument.

 


Copyright 2021, cxsecurity.com

 

Back to Top