RSS   Podatności dla 'Lizard'   RSS

2018-09-13
 
CVE-2018-16985

CWE-125
 

 
In Lizard (formerly LZ5) 2.0, use of an invalid memory address was discovered in LZ5_compress_continue in lz5_compress.c, related to LZ5_compress_fastSmall and MEM_read32. The vulnerability causes a segmentation fault and application crash, which leads to denial of service.

 
2018-05-26
 
CVE-2018-11498

CWE-119
 

 
In Lizard v1.0 and LZ5 v2.0 (the prior release, before the product was renamed), there is an unchecked buffer size during a memcpy in the Lizard_decompress_LIZv1 function (lib/lizard_decompress_liz.h). Remote attackers can leverage this vulnerability to cause a denial of service via a crafted input file, as well as achieve remote code execution.

 

 >>> Vendor: Lizard project 2 Produkty
Lizard
LZ5


Copyright 2021, cxsecurity.com

 

Back to Top