RSS   Podatności dla 'Uri-js'   RSS

2018-06-04
 
CVE-2017-16021

CWE-400
 

 
uri-js is a module that tries to fully implement RFC 3986. One of these features is validating whether or not a supplied URL is valid or not. To do this, uri-js uses a regular expression, This regular expression is vulnerable to redos. This causes the program to hang and the CPU to idle at 100% usage while uri-js is trying to validate if the supplied URL is valid or not. To check if you're vulnerable, look for a call to `require("uri-js").parse()` where a user is able to send their own input. This affects uri-js 2.1.1 and earlier.

 


Copyright 2020, cxsecurity.com

 

Back to Top