RSS   Podatności dla 'Shopxo'   RSS

2022-05-02
 
CVE-2022-28056

CWE-732
 

 
ShopXO v2.2.5 and below was discovered to contain a system re-install vulnerability via the Add function in app/install/controller/Index.php.

 
2022-03-20
 
CVE-2020-26007

CWE-434
 

 
An arbitrary file upload vulnerability in the upload payment plugin of ShopXO v1.9.0 allows attackers to execute arbitrary code via uploading a crafted PHP file.

 
 
CVE-2020-26008

CWE-434
 

 
The PluginsUpload function in application/service/PluginsAdminService.php of ShopXO v1.9.0 contains an arbitrary file upload vulnerability which allows attackers to execute arbitrary code via uploading a crafted PHP file.

 
2021-04-14
 
CVE-2020-19778

CWE-269
 

 
Incorrect Access Control in Shopxo v1.4.0 and v1.5.0 allows remote attackers to gain privileges in "/index.php" by manipulating the parameter "user_id" in the HTML request.

 
2021-03-15
 
CVE-2021-27817

CWE-434
 

 
A remote command execution vulnerability in shopxo 1.9.3 allows an attacker to upload malicious code generated by phar where the suffix is JPG, which is uploaded after modifying the phar suffix.

 
2020-08-17
 
CVE-2020-24220

CWE-78
 

 
ShopXO v1.8.1 has a command execution vulnerability. Attackers can use this vulnerability to execute arbitrary commands and gain control of the server.

 
2019-01-10
 
CVE-2019-5887

CWE-22
 

 
An issue was discovered in ShopXO 1.2.0. In the UnlinkDir method of the FileUtil.php file, the input parameters are not checked, resulting in input mishandling by the rmdir method. Attackers can delete arbitrary files by using "../" directory traversal.

 
 
CVE-2019-5886

CWE-264
 

 
An issue was discovered in ShopXO 1.2.0. In the application\install\controller\Index.php file, there is no validation lock file in the Add method, which allows an attacker to reinstall the database. The attacker can write arbitrary code to database.php during system reinstallation.

 


Copyright 2022, cxsecurity.com

 

Back to Top