RSS   Podatności dla 'Libxcursor'   RSS

2018-08-01
 
CVE-2015-9262

CWE-119
 

 
_XcursorThemeInherits in library.c in libXcursor before 1.1.15 allows remote attackers to cause denial of service or potentially code execution via a one-byte heap overflow.

 
2017-12-01
 
CVE-2017-16612

CWE-190
 

 
libXcursor before 1.1.15 has various integer overflows that could lead to heap buffer overflows when processing malicious cursors, e.g., with programs like GIMP. It is also possible that an attack vector exists against the related code in cursor/xcursor.c in Wayland through 1.14.0.

 
2013-06-15
 
CVE-2013-2003

 

 
Integer overflow in X.org libXcursor 1.1.13 and earlier allows X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to the _XcursorFileHeaderCreate function.

 

 >>> Vendor: X 33 Produkty
X11
X.org
Libxfont
X server
X.org-xserver
X.org x11
Libxext
Libxfixes
Libxi
Libxrandr
Libxres
Libxv
Libxvmc
Libxxf86dga
Libdmx
Libchromexvmc
Libchromexvmcpro
Libfs
Libx11
Libxxf86vm
Libxt
Libxcursor
Libxp
Libxtst
Libxcb
Libxrender
Libxinerama
X display manager
Libglx
Xf86-video-intel
X window system
Xorg-server
Xfree86


Copyright 2021, cxsecurity.com

 

Back to Top