Vulnerability CVE-2001-0522


Published: 2001-08-14   Modified: 2012-02-12

Description:
Format string vulnerability in Gnu Privacy Guard (aka GnuPG or gpg) 1.05 and earlier can allow an attacker to gain privileges via format strings in the original filename that is stored in an encrypted file.

Type:

CWE-Other

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.5/10
6.4/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
GNU -> Privacy guard 

 References:
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000399
http://download.immunix.org/ImmunixOS/7.0/updates/IMNX-2001-70-023-01
http://online.securityfocus.com/archive/1/188218
http://www.calderasystems.com/support/security/advisories/CSSA-2001-020.0.txt
http://www.debian.org/security/2001/dsa-061
http://www.gnupg.org/whatsnew.html#rn20010529
http://www.kb.cert.org/vuls/id/403051
http://www.linux-mandrake.com/en/security/2001/MDKSA-2001-053.php3
http://www.novell.com/linux/security/advisories/2001_020_gpg_txt.html
http://www.redhat.com/support/errata/RHSA-2001-073.html
http://www.securityfocus.com/bid/2797
http://www.turbolinux.com/pipermail/tl-security-announce/2001-June/000439.html
https://exchange.xforce.ibmcloud.com/vulnerabilities/6642

Copyright 2021, cxsecurity.com

 

Back to Top