Vulnerability CVE-2002-0655


Published: 2002-08-12   Modified: 2012-02-12

Description:
OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, does not properly handle ASCII representations of integers on 64 bit platforms, which could allow attackers to cause a denial of service and possibly execute arbitrary code.

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.5/10
6.4/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Oracle -> Application server 
Oracle -> Corporate time outlook connector 
Oracle -> Http server 
Openssl -> Openssl 
Apple -> Mac os x 

 References:
http://www.kb.cert.org/vuls/id/308891
http://www.cert.org/advisories/CA-2002-23.html
http://www.securityfocus.com/bid/5364
http://www.linux-mandrake.com/en/security/2002/MDKSA-2002-046.php
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000513
ftp://ftp.freebsd.org/pub/FreeBSD/CERT/advisories/FreeBSD-SA-02:33.openssl.asc
ftp://ftp.caldera.com/pub/security/OpenLinux/CSSA-2002-033.1.txt
ftp://ftp.caldera.com/pub/security/OpenLinux/CSSA-2002-033.0.txt

Copyright 2021, cxsecurity.com

 

Back to Top