Vulnerability CVE-2005-2416


Published: 2005-08-03   Modified: 2012-02-12

Description:
Multiple cross-site scripting (XSS) vulnerabilities in Contrexx before 1.0.5 allow remote attackers to inject arbitrary web script or HTML via the (1) term parameter to the search module or (2) title in the blog aggregation module.

Vendor: Astalavista it engineering
Product: Contrexx 
Version: 1.0.4;

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None

 References:
http://www.hardened-php.net/advisory_112005.59.html
http://xforce.iss.net/xforce/xfdb/21487
http://xforce.iss.net/xforce/xfdb/21484
http://www.securityfocus.com/bid/14352
http://www.osvdb.org/18169
http://www.osvdb.org/18168
http://securitytracker.com/id?1014554
http://secunia.com/advisories/16169
http://marc.theaimsgroup.com/?l=bugtraq&m=112206702015439&w=2

Related CVE
CVE-2006-1293
Cross-site scripting (XSS) vulnerability in index.php in Contrexx CMS 1.0.8 and earlier allows remote attackers to inject arbitrary web script or HTML via the query string (PHP_SELF).
CVE-2005-2417
Contrexx before 1.0.5 allows remote attackers to obtain sensitive information via a direct request to /config/version.xml.
CVE-2005-2415
Multiple SQL injection vulnerabilities in Contrexx before 1.0.5 allow remote attackers to execute arbitrary SQL commands via the (1) value parameter to the poll module or (2) pId parameter to the gallery module.

Copyright 2019, cxsecurity.com

 

Back to Top