Vulnerability CVE-2005-4270


Published: 2005-12-15   Modified: 2012-02-12

Description:
Buffer overflow in Watchfire AppScan QA 5.0.609 and 5.0.134 allows remote web servers to execute arbitrary code via an HTTP 401 response with a WWW-Authenticate header containing a long Realm field.

See advisories in our WLB2 database:
Topic
Author
Date
High
Watchfire AppScan QA Remote Code Execution
Mariano Nu?ez Di...
16.12.2005

Type:

CWE-Other

Vendor: Watchfire
Product: Appscan qa 
Version: 5.0.609; 5.0.134;

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.5/10
6.4/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial

 References:
http://securityreason.com/securityalert/260
http://securitytracker.com/id?1015362
http://www.cybsec.com/vuln/CYBSEC_Security_Advisory_AppScanQA_RemoteCodeExec.pdf
http://www.securityfocus.com/archive/1/419586/100/0/threaded
http://www.securityfocus.com/bid/15873
http://www.vupen.com/english/advisories/2005/2933

Copyright 2019, cxsecurity.com

 

Back to Top