Vulnerability CVE-2005-4890


Published: 2019-11-04   Modified: 2019-11-05

Description:
There is a possible tty hijacking in shadow 4.x before 4.1.5 and sudo 1.x before 1.7.4 via "su - user -c program". The user session can be escaped to the parent session by using the TIOCSTI ioctl to push characters into the input buffer to be read by the next process.

See advisories in our WLB2 database:
Topic
Author
Date
Med.
tty hijacking redux
mancha
21.05.2013

Type:

CWE-20

(Improper Input Validation)

CVSS2 => (AV:L/AC:L/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.2/10
10/10
3.9/10
Exploit range
Attack complexity
Authentication
Local
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
Sudo project -> SUDO 
Redhat -> Enterprise linux 
Debian -> Shadow 
Debian -> Debian linux 

 References:
http://www.openwall.com/lists/oss-security/2012/11/06/8
http://www.openwall.com/lists/oss-security/2013/05/20/3
http://www.openwall.com/lists/oss-security/2013/11/28/10
http://www.openwall.com/lists/oss-security/2013/11/29/5
http://www.openwall.com/lists/oss-security/2014/10/20/9
http://www.openwall.com/lists/oss-security/2014/10/21/1
http://www.openwall.com/lists/oss-security/2014/12/15/5
http://www.openwall.com/lists/oss-security/2016/02/25/6
https://access.redhat.com/security/cve/cve-2005-4890
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2005-4890
https://security-tracker.debian.org/tracker/CVE-2005-4890

Copyright 2021, cxsecurity.com

 

Back to Top